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Overview

Overview

Creating a text document of 50 pages or more should usual be done using a text processing 
program with DTP (desktop publishing) capabilities. OpenOffice.org Writer provides these 
facilities with its Style and Template features. It is desirable to have a good understanding of 
the text processing capabilities of your program. By covering all the required functions, this 
document attempts to save you from getting bogged down in trying to learn every detail of 
OpenOffice.org Writer before starting on your thesis. Some topics will be treated in detail 
while many will be referred to the User Guide.

This document addresses readers who have an idea what OpenOffice.org is about. However, 
even an absolute beginner should be able to conquer the difficulties by frequently referring to 
the User Guide and the Help facility of OpenOffice.org.
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Writing a Thesis with OpenOffice.org

General Procedure

Before keying in a thesis, a rudimentary knowledge of OpenOffice.org Writer is required. 
Terms such as paragraph styles, page styles or templates should be familiar. The thesis must be 
planned in advance. Such things as inserting graphics and lists and the document structure 
must be decided. As far as possible, do a dry run with short dummy text or similar material. 
Referring to the User Guide or even to related newsgroups can be very helpful.

When problems occur, it is frequently due to lack of prior planning or knowledge. That means 
some principles of OpenOffice.org Writer were not known or understood or Writer was used 
while wearing an MS Word hat. This is naturally not too serious but often leads to unnecessary 
effort or in the worst case to problems.

OpenOffice.org Writer contains a lot of Desk Top Publishing (DTP) functionality. For one 
thing, text is easily controlled. Particularly, things can be done the way one wants to do them. 
This has two drawbacks: One has to know what one wants, and the document has to be 
organized. The incredible advantage is that one can write the thesis from A to Z without the 
need of inserting hard page breaks, size-adjusting graphics, etc. And in the end, the thing looks 
just as it was intended.

Security of Data (Backups)

Only a few general comments are indicated for this topic. Frequent saving and backing up is 
only sensible, when dealing with data which may have taken hours to generate. Potential 
problems with the various file formats cannot be totally ruled out.

• In the Tools menu, select Options > Load/Save > General, check Always create backup 
copy and AutoSave every xx Minutes (substitute 5 or 10 for for xx as desired), then select 
Text document under heading Document type. 

• Save your work several times a day onto an external data medium. In doing so, keep more 
than just the last-saved update. The reason for this is that hardware or software could 
already have written corrupted data onto the hard drive while otherwise working fine. Only 
when opened afresh after a completed work session will Writer greet you with the friendly 
message that the file cannot be read anymore. A recommended strategy is to place a number 
of diskettes on a shelf, pull the bottom-most out, save your data and store the diskette on top 
of the heap. As an alternative, label the diskettes by weekdays and use them accordingly.

• Be sure to create and save different data types separately. For example, an embedded object, 
such as a graphic, should be stored safely, or better, not be embedded in the first place but 
linked instead. This has the advantage that even a larger thesis can be saved daily onto a 
diskette and stored. This is achieved by saving only the updated data on a daily basis and 
powering up the CD burner once a week.

Writing a Thesis with OpenOffice.org 1
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Printer 

If different printers are to be used from time to time, then you should always finalize your 
document in Postscript format. Never submit your work to another printer in OpenOffice.org 
Writer file format, as Writer would then adapt the document to be compatible with that 
printer's configuration. This could, at the very least, result in different line and page breaks, 
which would probably not be desirable. Information on Postscript in conjunction with 
OpenOffice.org Writer can be found in the OpenOffice.org Writer Help. From the menu select 
Help > Contents: At the Index tab type in “Postscript”.

Windows users will need a PostScript printer driver such as the Apple LaserWriter driver. 
Unix/Linux users probably have PostScript already installed, and can use the “Generic 
Printer”.

Master Document

OpenOffice.org Writer can use Master Documents to make document management easier. A 
Master Document incorporates each chapter of a book as an individual OpenOffice.org Writer 
file. Using a Master Document for a normal thesis is not usually necessary as OpenOffice.org 
Writer is stable and sufficiently powerful to manage even quite large documents. Using a 
Master Document is more appropriate when a work has several authors, or where individual 
chapters are created separately, and then must be incorporated into a complete work. 

Templates

Thanks to the Template concept in OpenOffice.org Writer, a thesis can be written chapter by 
chapter and, towards the end, joined into a big document. Before starting with the actual 
writing, one should experiment with a lot of dummy text to come up with a desired layout. 
Once this has been determined, it should be translated into an appropriate array of page, 
character and paragraph styles and saved as a template file.

Now the template file can be used as the basis for each chapter of the thesis. If during the 
work, layout changes are desired these can be incorporated into the template. Next time a 
chapter is opened the changes to the template will be noted, and can be accepted or rejected as 
required.

Page Structure, different types of Page Numbering

The title page needs neither header nor footer. The subsequent Table of Contents – which may 
extend over more than one page – uses Roman page numbering, followed by the actual body of 
the document, which has Arabic page numbering and the chapter title in the header. 
OpenOffice.org Writer and the use of page styles requires a bit of advanced planning. This has 
the advantage that the text layout can be altered for the whole document at any time.

The actual page style is indicated in the Status Bar in the second box from the left as shown in 
Illustration 1, Default in this case. By double clicking in this box, the page style can be 
modified, while right-clicking allows changing to a different page style.

Writing a Thesis with OpenOffice.org 2
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Page styles are best modified by opening the Stylist (by selecting Format > Stylist or simply 
by pressing F11). Notice the five icons at the top of the Stylist. Select Page Styles. Right-click 
then on the style in question and click Modify.... This opens the Page Style dialog box which 
allows the style to be modified at will, as shown in Illustration 2.

By opening the individual tabs, one can modify the various attributes of the page style. Look 
into these tabs to get an idea what is available. For example looking at the tab Organizer: As 
Illustration 2 shows, the page following a page based on the style First Page is based on the 
style Table of Contents.

Writing a Thesis with OpenOffice.org 3
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After the style First page has 
been modified to suit your 
needs and taste, the second 
and subsequent pages will 
automatically be based on the 
style Table of Contents until 
you decide to again assign a 
different style to a new page, 
as would be the case when the 
actual document text begins.

Usually, the Table of  
Contents pages will be 
numbered by Roman 
numerals. For this, open the 
Page Style dialog box in a 
Table of Contents page, click 
on the Page tab and, in 
Layout Settings > Format, 
select Roman numerals 
(lower-case or upper-case) as 
shown in the Format edit box of Illustration 3.

Furthermore, by opening the tab Header, add a header to indicate that this page is a Table of 
Contents page.

Writing a Thesis with OpenOffice.org 4
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The page style change from the last Table of Contents page to the first normal text page cannot 
be as conveniently, i.e. automatically, accomplished as the change from style First Page to 
style Table of Contents because a Table of Contents can, of course, extend over two or more 
pages. The solution is to insert a manual page break at the end of the Table of Contents and 
selecting for this new page a style that defines the formatting of a regular text page. This is 
achieved by choosing Insert > Manual Break... and then, in the Insert Break dialog box, 
selecting Page break as Type and Default as Style, as shown in Illustration 4. (This assumes 
that the style Default has been tailored to define all the desired attributes and formats of a 
regular text page.)

Note: Page breaks in OpenOffice.org 
Writer are controlled with paragraph 
formats. If a change to a page break is 
required, place the cursor into the 
paragraph just below  the page break (i.e. 
the paragraph below  the thin, blue line) 
and choose Format > Paragraph... > 
Text Flow. This brings up the 
Paragraph dialog box. The various page 
attributes such as the page style or the 
page number to be displayed, say, in the 
footer, can then be modified.

Text Section of a Page

The layout of the text section of a page is defined under the heading Page in the Page Style 
dialog box. (Refer to the paragraph, “Page Structure, different types of Page Numbering” and 
Illustration 2, on how to open this dialog box.) Note that under the heading Margins, only the 
text section is defined, headers and footers are placed into the margin areas by OpenOffice.org 
Writer. Example: Assume a bottom margin of 4 cm height, containing a footer for indicating 
the page number, is desired. To achieve this, specify 2.00 cm as page bottom margin, the click 
on the heading Footer of the Page Style dialog box, specify 1.5 cm as Spacing and 0.50 cm as 
Height of the footer. This results in the bottom margin layout shown in Illustration 5.

By returning to the Page display of the Page Style 
dialog box, it can be seen that the page layout can 
be selected as Right and left or as Mirrored (beside 
Only right and Only left). If the thesis is to be 
organized like a book, Mirrored would be selected. 
In this case, Same content left/right check boxes 
would have to be unchecked in the Header and 
Footer display of the Page Style dialog box. 
However, unless it is a prescribed requirement, it is 
considerably easier to stick with a single-page 
layout as a double-page layout calls for 
considerably more effort.
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Pages in Landscape Orientation

If some pages in the document require a different page layout or orientation, then – and this 
should be obvious by now – page styles come to the rescue again. As an example, look at a 
page that requires landscape orientation. Create a new page style by opening the Stylist 
(pressing F11), give it a fitting name (e.g. Landscape) and, after clicking tab Page, select 
Landscape as the orientation. 

Use Insert > Manual Break at the appropriate location in the document and select the page 
style Landscape from the style dropdown so that it applies to the new page. At the end of the 
section requiring landscape orientation, another manual page break is called for and the page 
style has to be returned to Default or Standard or whatever.

A new Chapter starts with a new Page

The actual page style can be set with paragraph styles.  A good example would be starting a 
chapter with a new page. For this, one instructs paragraph style Heading 1 to start a new page. 
In Paragraph Style > Text Flow, check Enable in section Breaks, as shown in Illustration 6. 
If required, a change in page style can also be achieved using this method.

Change in Page 
Numbering

If, at any point in the 
document, page 
numbering should start 
anew again it should 
always be done via 
Insert > Manual 
Break... > Page break. 
If instead the page 
number were changed by 
correcting the number in 
the field command Page 
number it would not be 
reflected by 
OpenOffice.org Writer's 
page count mechanism, 
in the Table of Contents. 
If the first page of the 
document is to have a 
page number other than 1 then the paragraph style of the first paragraph has to be accordingly 
adjusted: Place the cursor into the first line, select Format > Paragraph, tab Text Flow, in 
section Breaks check Enable and With Page Style and, finally, set the desired page style and 
page number.

Writing a Thesis with OpenOffice.org 6
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Headings

The next few sections deal with manipulating paragraphs with paragraph styles. Paragraph 
styles in OpenOffice.org Writer are hierarchically organized. One can see the hierarchy of all 
paragraph styles if one sets the Stylist view to Hierarchical as shown in Illustration 7. 

One can see in Illustration 7 that all paragraph styles are based on paragraph style Default. This 
means all paragraph styles “inherit” the settings of paragraph style Default unless one or more 
settings have been modified in a particular paragraph style or in one of its parent paragraph 
styles.

Example: Assume the font of paragraph style Default is Times New Roman whereas the font of 
paragraph style Heading (the parent of all heading styles) has been set to Arial. If you now 
change the font of the (hierarchically topmost) paragraph style Default to Garamond, then this 
change is inherited by all paragraph styles in the paragraph style branch Text body. However, 
in all heading paragraph styles, the font Arial is retained as it has been set before. 

If it is desirable to change the font (or any other 
characteristic) of all heading styles, then you 
simply make this change in the parent paragraph 
style Heading. A paragraph style can be modified 
by use of the stylist: Select the style and, via the 
context menu, select Modify.... Alternatively, place 
the cursor in any paragraph with this paragraph 
style and, by right-clicking, call up the context 
menu and select Modify....

To Number or not to Number 
Headings

OpenOffice.org Writer can, of course, 
automatically number all chapters and sections. 
For this, each chapter has to be assigned one of the 
heading paragraph styles, Heading 1 to Heading 
10. The numbering is then activated via Tools > 
Outline Numbering. Of course, there are 
introductions, literature lists and appendices which 
are supposed to be treated as headings but either 
not numbered at all or numbered in a different 
way.

The solution for this problem is cloning a 
paragraph style. Say, the introduction is to have 
paragraph style Heading 1 but without numbering. Referring to Illustration 8 below, set the 
cursor into paragraph Introduction and assign paragraph style Heading 1 to it with a double-
click in the Stylist. Then click icon New Style from Selection and give it an appropriate name, 
e.g. Heading 1 without numbering.
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Note that style Heading 1 without numbering is now a “child” of style Heading 1 Thus, any 
modification made to style Heading 1 will automatically be reflected in style Heading 1 
without numbering as shown in Illustration 9 below.
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Numbering of Appendices and Adding them to the Table of Contents

Page numbering of pages containing appendices is continual. However, chapter numbering is 
not included for appendices. This means you should apply the above-described trick of using 
paragraph style Heading 1 without numbering. Numbering of appendices is most conveniently 
done by use of a number range as described below. You insert the word Appendix at the start 
of the appendix, change the paragraph style to Heading 1 without numbering, select Insert > 
Fields > Other... and then tab Variables. Refer to Illustration 10.

Writing a Thesis with OpenOffice.org 9
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Now, select A B C as format. This procedure has to be repeated for every appendix.

In order to have the appendix headings listed in the Table of Contents, every appendix heading 
has to be selected and registered by selecting Insert > Indexes and Tables > Entry.... The 
ensuing dialog box Insert Index Entry is shown in Illustration 11 below.

Writing a Thesis with OpenOffice.org 10
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Select Table of Contents from the choice of indexes, then click Insert and Close.

Controlling Text Flow

The whole text flow of a document should be controlled through the Text body paragraph style 
or one of its successors. Refer to Illustration 12 below.

In the Paragraph Style: Text body dialog box, under tab Text Flow, automatic hyphenation 
should be checked. More important is the activation of orphan and widow control. This 
prevents a single line of a paragraph from being placed at the start or end of a page. Setting 
orphan control to at least 2 lines ensures that at least 2 lines of a (longer) paragraph are placed 
at the bottom of a page, otherwise, the paragraph starts at the next page. 

Indenting the first Line of a Paragraph

Indenting the first line of a paragraph is standard practice. However, this is often a matter of 
personal taste, or there may be a standard set by the University or the Thesis Supervisor.  Set 
up indenting in Paragraph Style > Indents&Spacing. Unselect Automatic, and enter the first 
line indent amount in the edit box.

Writing a Thesis with OpenOffice.org 11
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A frequent practice, is to indent, but not on the first paragraph after a heading or after an 
illustration.

For this, paragraph style Text body has to be modified as it is the default “next style” of all 
headings and the “previous style” of all text styles. Here, Spacing > Above paragraph has to 
be set to 0. Line spacing should be set to 2 to 3 pt (0.7 ...1.2 cm) for a 10-pt font . Note: 
OpenOffice.org Writer automatically translates other units of length into cm (or the preset unit 
of length). Refer to Illustration 13.

Writing a Thesis with OpenOffice.org 12
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Now, Text body indent has to be selected as Next Style, as shown in Illustration 14. No change 
to paragraph style Text body indent is required as it is based on  paragraph style Text body and 
thus “inherits” 0 cm as paragraph spacing and 3 pt (0.11 cm) as Line spacing.

Writing a Thesis with OpenOffice.org 13
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When one starts the first paragraph of a chapter (by hitting Enter after typing the chapter title), 
then this paragraph is governed by the parameters of paragraph style Text body, as desired 
without indentation of the first line. When hitting Enter at the end of this paragraph, a new 
paragraph is started which is based on paragraph style Text body indent and this holds true for 
all subsequent paragraphs. See Illustration 15.

After inserting a graphic or a list, the subsequent paragraph has to be manually set to paragraph 
style Text body via the Stylist. It is a good idea to check the correctness of all first-line indents 
after the whole thesis has been written. It is quite possible for some of these paragraphs end up 
at wrong places after some heavy editing. For example, if the first paragraph of a chapter is 
split, the second half of this original paragraph is also based on paragraph style Text body 
instead of paragraph style Text body indent.

Marking (or “Tagging”?) with Character Styles

For highlighting names of authors or foreign-language phrases, italics can be used. However, a 
more elegant way is the use of character styles. This has the advantage that a particular 
character style can be searched. Thus you don't have to search for all words or phrases in italics 
but - more focused - for “Author” or “Foreign-language phrase”. Also, the format of each style 
can be centrally modified at any time This is particularly important if only towards the end you 
decide if you want to highlight certain things at all. If not, you just cancel the highlighting.

Writing a Thesis with OpenOffice.org 14
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Cross-referencing

The usual method of cross-referencing in OpenOffice.org Writer is to first set and then insert a 
reference. There is no mechanism to set a cross-reference to a chapter heading without setting a 
reference in this chapter. This should not pose too big a problem but rather be beneficial to 
organizing the work as a reference remains valid even after the wildest reorganization. Refer to 
Illustration 16.

A reference can simply be set at the cursor position. In addition, also a selected word or block 
of text can used as reference. Make sure to assign meaningful (long) names for your 
references, for these are not so easy to accidentally rename or delete.

The only way to delete a reference is to select it via the Navigator (<F5>) and delete it.

Bibliography

The OpenOffice.org Writer Help and the User Guide both give instructions on making a 
bibliographic database, and on using this database in the document.  A small bibliography 
could be typed directly into the text of the document, but as the bibliography gets larger, more 
flexibility is obtained by using the database method.

Writing a Thesis with OpenOffice.org 15
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Graphics

Working with graphics is a rather complex subject, therefore only that aspect involving how to 
insert graphics into a OpenOffice.org Writer document will be covered here. 

Individual graphics can be inserted by selecting Insert > Graphics > From File....

If you have a large number of graphics to insert it may pay to create a temporary gallery (by 
selecting Tools > Gallery) where you collect all graphics for your thesis and then drag & drop 
them from there as the need arises. Graphics should always be inserted with the Link button in 
the Insert Graphics dialog box checked. This ensures that the main document is kept slim, all 
the graphics are always up-to-date and, in the case of data corruption in, or loss of the main 
document, the graphics are stored separately. Preferably, you should store the graphics in a 
separate folder. If you want to reorganize your graphics on your hard drive such as move it into 
a different folder, then this is no problem. By selecting Edit > Links ..., you can check all 
graphics in question and, after clicking on Modify..., choose the new folder. Refer to 
Illustration 17.

By using this dialog box, you can also break the links (by clicking on Break Link) if, for 
example, you want to send a copy of your thesis to a lector and want to make sure all graphics 
arrive correctly.

Inserting graphics via OLE is not recommended. From the viewpoint of data security it is more 
meaningful to export the graphic from its originating application and link it to OpenOffice.org 
Writer. If data are to be updated, simply export the graphic again from its native application. 
Sometimes, of course, it is more convenient or even necessary to use OLE. In this case,  back 
up your data! If possible save data in its native format and into a separate folder. Also it would 
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be prudent to save the actual OpenOffice.org Writer document in another format, for example, 
RTF, in order to have at least the text saved separately.

Notice also that if an OLE object is scaled without opening the corresponding OLE application, 
then only the preview will be scaled, which can lead to some rather unpleasant results. 
Therefore, always open the OLE application before scaling.

If you insert a graphic via Insert > Graphics > From File..., it will be anchored to a 
paragraph. This means that the graphic is joined to this paragraph and can be moved with the 
paragraph, yet does not necessarily follow the paragraph. If, at the end of a page, there isn't 
enough space for the graphic, then text of the next paragraph is pulled up to fill the page and 
the graphic is placed at the top of the next page. Should that be undesirable, then the graphic 
should be anchored “as character” by right-clicking the graphic, selecting Anchor, then As 
Character and placing the graphic into an empty paragraph.

When a graphic has been selected it can be given a title by selecting Insert > Caption. 
OpenOffice.org Writer adds an additional text frame around the graphic. A list of figures can 
then be generated. A disadvantage of automatically-generated captions is that no footnotes can 
be incorporated. If that is a requirement, it can be done as follows. One needs a paragraph style 
Graphic with Character whose Next Style is Graphic and whose Text Flow – under heading 
Options - is set to Keep with next paragraph. By using this paragraph style, one generates an 
empty paragraph into which the graphic is placed. The caption of the graphic is now entered 
into the next paragraph. For automatic numbering, the method described in chapter Numbering 
of Appendices and Adding them to the Table of Contents should be employed by selecting 
Drawing as the selection of Number range. (See also the paragraph “Footnotes” below.)

Formulas 

Pressing F2 while the cursor is in a text table opens the Formula bar. Clicking the icon opens a 
submenu, from which one can insert a formula into the cell of a table by putting the cursor 
either in the cell in the table or at the position in the document at which the result should 
appear. 

The formula appears in the input line. To specify a range of cells in a table, select the desired 
cells with the mouse. The corresponding cell references also appear in the input line. Enter 
additional parameters, as necessary, and click Apply to confirm the entry. A formula can also 
be entered directly, if the appropriate syntax is known. This is necessary, for example, in the 
Insert Fields and Edit Fields dialogs.

For details, see the User Guide.

Footnotes

Settings for footnotes are made at two places in OpenOffice.org Writer. Document-related 
settings are made under Tools > Footnotes.... In addition, settings for footnotes are also 
available in page styles. This is where the appearance of the footnote area is tailored. Using 
page style also allows one to set the maximum height of the footnote area, whereby 
OpenOffice.org Writer possibly pushes the footnote to the next page. However, this option will 
be rarely used in a thesis.

Writing a Thesis with OpenOffice.org 17

http://documentation.openoffice.org/manuals/OOo1.x.x/user_guide.pdf


Writing a Thesis with OpenOffice.org

In order to switch between footnote anchor and text, one just clicks on the desired reference.

Occasional footnotes may be entered even when graphics captions are numbered. Select Insert 
> Footnote, Select Character and enter a character of your choice, or go to the Special 
Characters button (...) and select one from there. If automatic graphics captions are used, and 
you chose to number the footnotes, they will not automatically be updated when new footnotes 
are inserted.

Tables

If the thesis needs to contain a large number of tables that should look alike then a desired 
table form can be created and given a name via Format > Autoformat. This table format can 
then be transferred to another table, again via Format > Autoformat. A table with many rows 
and columns should be used since only then will the layout be accepted without problems. 

Table of Contents

To generate a Table of Contents, place the cursor at the desired location and select Insert > 
Indexes and Tables > Indexes and Tables.... After editing the entries under tab Index/Table, 
click Entries. Under Structure, <E#> stands for chapter #, <E> for chapter text, <T> for tab 
stop and <#> for page #. Refer to Illustration 18 and to the User Guide for details.

In order to put a space character between the chapter # and the chapter text, the space character 
can simply be incorporated into the chapter title structure:

<E#> <ET><T><#>
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Similarly, if a tab stop is desired between chapter # and chapter text, the structure would look 
like this:

<E#><T><ET><T><#>

In this case, a second tab stop has to be inserted in the paragraph styles Heading 1 to Heading 
10.

If no change has been made to the Table of Contents format, the Table of Contents can be 
updated via Tools > Update. However if the format has been changed, the cursor has to be 
placed into the Table of Contents and Insert > Indexes and Tables > Indexes and Tables... 
has to be called up. 

Unfortunately, the page number formats of the various page styles are not automatically 
adopted by the Table of Contents. This means that anomalies in the Table of Contents, arising 
from this cause will have to be corrected manually. See the paragraph on “Change of Page 
Numbering.”

Marginalia 

Marginalia are rarely seen in a thesis; but if you want to use them you can 
implement them by means of text frames (Insert > Frame...) as in the example 
shown here. If you have a two-sided layout, the marginalia have to be placed on 
the outer page margin. For this, you can create a paragraph-anchored frame with 
the check box To paragraph. Refer to Illustration 19. The text box can be dragged 
and resized with the mouse.

Writing a Thesis with OpenOffice.org 19
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If you want to insert another marginal somewhere else in your text, just copy the existing one. 
Whoever feels they have the time and inclination, may wish to write a macro.

In OpenOffice.org Writer, marginalia can also be generated and modified via paragraph styles 
or frame styles. A paragraph based on paragraph style with marginalia has a left margin of 4 
cm. You have to use a marginalia text frame in conjunction with this paragraph. In this case, 
however, the marginal is always on the left side of the text.
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Public Documentation License, Version 1.0
1.0 DEFINITIONS. 

1.1. "Commercial Use" means distribution or otherwise 
making the Documentation available to a third party. 

1.2. "Contributor" means a person or entity who creates or 
contributes to the creation of Modifications. 

1.3. "Documentation" means the Original Documentation or 
Modifications or the combination of the Original 
Documentation and Modifications, in each case including 
portions thereof.

1.4. "Electronic Distribution Mechanism" means a mechanism 
generally accepted for the electronic transfer of data. 

1.5. "Initial Writer" means the individual or entity identified 
as the Initial Writer in the notice required by the Appendix. 

1.6. "Larger Work" means a work which combines 
Documentation or portions thereof with documentation or 
other writings not governed by the terms of this License. 

1.7. "License" means this document. 

1.8. "Modifications" means any addition to or deletion from 
the substance or structure of either the Original 
Documentation or any previous Modifications, such as a 
translation, abridgment, condensation, or any other form in 
which the Original Documentation or previous Modifications 
may be recast, transformed or adapted.  A work consisting of 
editorial revisions, annotations, elaborations, and other 
modifications which, as a whole represent an original work of 
authorship, is a Modification.  For example, when 
Documentation is released as a series of documents, a 
Modification is: 

A. Any addition to or deletion from the contents of the 
Original Documentation or previous Modifications. 

B. Any new documentation that contains any part of the 
Original Documentation or previous Modifications. 

1.9. "Original Documentation" means documentation 
described as Original Documentation in the notice required by 
the Appendix, and which, at the time of its release under this 
License is not already Documentation governed by this 
License. 

1.10. "Editable Form" means the preferred form of the 
Documentation for making Modifications to it. The 
Documentation can be in an electronic, compressed or 
archival form, provided the appropriate decompression or de-
archiving software is widely available for no charge. 

1.11. "You" (or "Your") means an individual or a legal entity 
exercising rights under, and complying with all of the terms of 
this License or a future version of this License issued under 
Section 5.0 ("Versions of the License"). For legal entities, 
"You" includes any entity which controls, is controlled by, or 
is under common control with You. For purposes of this 
definition, "control" means (a) the power, direct or indirect, to 
cause the direction or management of such entity, whether by 
contract or otherwise, or (b) ownership of more than fifty 

percent (50%) of the outstanding shares or beneficial 
ownership of such entity.

2.0 LICENSE GRANTS. 

2.1  Initial Writer Grant. 

The Initial Writer hereby grants You a world-wide, royalty-
free, non-exclusive license to use, reproduce, prepare 
Modifications of, compile, publicly perform, publicly display, 
demonstrate, market, disclose and distribute the 
Documentation in any form, on any media or via any 
Electronic Distribution Mechanism or other method now 
known or later discovered, and to sublicense the foregoing 
rights to third parties through multiple tiers of sublicensees in 
accordance with the terms of this License.  

The license rights granted in this Section 2.1 ("Initial Writer 
Grant") are effective on the date Initial Writer first distributes 
Original Documentation under the terms of this License. 

2.2. Contributor Grant. 

Each Contributor hereby grants You a world-wide, royalty-
free, non-exclusive license to use, reproduce, prepare 
Modifications of, compile, publicly perform, publicly display, 
demonstrate, market, disclose and distribute the 
Documentation in any form, on any media or via any 
Electronic Distribution Mechanism or other method now 
known or later discovered, and to sublicense the foregoing 
rights to third parties through multiple tiers of sublicensees in 
accordance with the terms of this License.  

The license rights granted in this Section 2.2 ("Contributor 
Grant") are effective on the date Contributor first makes 
Commercial Use of the Documentation. 

3.0 DISTRIBUTION OBLIGATIONS. 

3.1. Application of License.

The Modifications which You create or to which You 
contribute are governed by the terms of this License, 
including without limitation Section 2.2 ("Contributor 
Grant").  The Documentation may be distributed only under 
the terms of this License or a future version of this License 
released in accordance with Section 5.0 ("Versions of the 
License"), and You must include a copy of this License with 
every copy of the Documentation You distribute. You may 
not offer or impose any terms that alter or restrict the 
applicable version of this License or the recipients' rights 
hereunder. However, You may include an additional 
document offering the additional rights described in Section 
3.5 ("Required Notices"). 

 3.2. Availability of Documentation.

Any Modification which You create or to which You 
contribute must be made available publicly in Editable Form 
under the terms of this License via a fixed medium or an 
accepted Electronic Distribution Mechanism. 

3.3. Description of Modifications.

[Document Title] 22



Public Documentation License, Version 1.0

All Documentation to which You contribute must identify the 
changes You made to create that Documentation and the date 
of any change. You must include a prominent statement that 
the Modification is derived, directly or indirectly, from 
Original Documentation provided by the Initial Writer and 
include the name of the Initial Writer in the Documentation or 
via an electronic link that describes the origin or ownership of 
the Documentation.  The foregoing change documentation 
may be created by using an electronic program that 
automatically tracks changes to the Documentation, and such 
changes must be available publicly for at least five years 
following release of the changed Documentation. 

3.4. Intellectual Property Matters.

Contributor represents that Contributor believes that 
Contributor's Modifications are Contributor's original 
creation(s) and/or Contributor has sufficient rights to grant the 
rights conveyed by this License.

3.5. Required Notices.

You must duplicate the notice in the Appendix in each file of 
the Documentation. If it is not possible to put such notice in a 
particular Documentation file due to its structure, then You 
must include such notice in a location (such as a relevant 
directory) where a reader would be likely to look for such a 
notice, for example, via a hyperlink in each file of the 
Documentation that takes the reader to a page that describes 
the origin and ownership of the Documentation.  If You 
created one or more Modification(s) You may add your name 
as a Contributor to the notice described in the Appendix. 

You must also duplicate this License in any Documentation 
file (or with a hyperlink in each file of the Documentation) 
where You describe recipients' rights or ownership rights. 

You may choose to offer, and to charge a fee for, warranty, 
support, indemnity or liability obligations to one or more 
recipients of Documentation. However, You may do so only 
on Your own behalf, and not on behalf of the Initial Writer or 
any Contributor. You must make it absolutely clear than any 
such warranty, support, indemnity or liability obligation is 
offered by You alone, and You hereby agree to indemnify the 
Initial Writer and every Contributor for any liability incurred 
by the Initial Writer or such Contributor as a result of 
warranty, support, indemnity or liability terms You offer. 

 3.6.  Larger Works.

You may create a Larger Work by combining Documentation 
with other documents not governed by the terms of this 
License and distribute the Larger Work as a single product. In 
such a case, You must make sure the requirements of this 
License are fulfilled for the Documentation.

4.0  APPLICATION OF THIS LICENSE. 

This License applies to Documentation to which the Initial 
Writer has attached this License and the notice in the 
Appendix.

5.0  VERSIONS OF THE LICENSE. 

5.1. New Versions.

Initial Writer may publish revised and/or new versions of the 
License from time to time. Each version will be given a 
distinguishing version number. 

5.2. Effect of New Versions.

Once Documentation has been published under a particular 
version of the License, You may always continue to use it 
under the terms of that version. You may also choose to use 
such Documentation under the terms of any subsequent 
version of the License published 
by______________________ [Insert name of the foundation, 
company, Initial Writer, or whoever may modify this 
License]. No one other than 
________________________[Insert name of the foundation, 
company, Initial Writer, or whoever may modify this License] 
has the right to modify the terms of this License. Filling in the 
name of the Initial Writer, Original Documentation or 
Contributor in the notice described in the Appendix shall not 
be deemed to be Modifications of this License.

6.0 DISCLAIMER OF WARRANTY. 

DOCUMENTATION IS PROVIDED UNDER THIS 
LICENSE ON AN "AS IS'' BASIS, WITHOUT 
WARRANTY OF ANY KIND, EITHER EXPRESSED OR 
IMPLIED, INCLUDING, WITHOUT LIMITATION, 
WARRANTIES THAT THE DOCUMENTATION IS FREE 
OF DEFECTS, MERCHANTABLE, FIT FOR A 
PARTICULAR PURPOSE OR NON-INFRINGING. THE 
ENTIRE RISK AS TO THE QUALITY, ACCURACY, AND 
PERFORMANCE OF THE DOCUMENTATION IS WITH 
YOU. SHOULD ANY DOCUMENTATION PROVE 
DEFECTIVE IN ANY RESPECT, YOU (NOT THE 
INITIAL WRITER OR ANY OTHER CONTRIBUTOR) 
ASSUME THE COST OF ANY NECESSARY SERVICING, 
REPAIR OR CORRECTION. THIS DISCLAIMER OF 
WARRANTY CONSTITUTES AN ESSENTIAL PART OF 
THIS LICENSE. NO USE OF ANY DOCUMENTATION IS 
AUTHORIZED HEREUNDER EXCEPT UNDER THIS 
DISCLAIMER.

7.0 TERMINATION. 

This License and the rights granted hereunder will terminate 
automatically if You fail to comply with terms herein and fail 
to cure such breach within 30 days of becoming aware of the 
breach. All sublicenses to the Documentation which are 
properly granted shall survive any termination of this License. 
Provisions which, by their nature, must remain in effect 
beyond the termination of this License shall survive. 

8.0 LIMITATION OF LIABILITY. 

UNDER NO CIRCUMSTANCES AND UNDER NO 
LEGAL THEORY, WHETHER IN TORT (INCLUDING 
NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL 
THE INITIAL WRITER, ANY OTHER CONTRIBUTOR, 
OR ANY DISTRIBUTOR OF DOCUMENTATION, OR 
ANY SUPPLIER OF ANY OF SUCH PARTIES, BE 
LIABLE TO ANY PERSON FOR ANY DIRECT, 
INDIRECT, SPECIAL, INCIDENTAL, OR 
CONSEQUENTIAL DAMAGES OF ANY CHARACTER 
INCLUDING, WITHOUT LIMITATION, DAMAGES FOR 
LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER 
FAILURE OR MALFUNCTION, OR ANY AND ALL 
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OTHER DAMAGES OR LOSSES ARISING OUT OF OR 
RELATING TO THE USE OF THE DOCUMENTATION, 
EVEN IF SUCH PARTY SHALL HAVE BEEN 
INFORMED OF THE POSSIBILITY OF SUCH 
DAMAGES. 

9.0 U.S. GOVERNMENT END USERS. 

If Documentation is being acquired by or on behalf of the U.S. 
Government or by a U.S. Government prime contractor or 
subcontractor (at any tier), then the Government's rights in 
Documentation will be only as set forth in this Agreement; 
this is in accordance with 48 CFR 227.7201 through 
227.7202-4 (for Department of Defense (DOD) acquisitions) 
and with 48 CFR 2.101 and 12.212 (for non-DOD 
acquisitions).

10.0 MISCELLANEOUS. 

This License represents the complete agreement concerning 
the subject matter hereof. If any provision of this License is 
held to be unenforceable, such provision shall be reformed 
only to the extent necessary to make it enforceable. This 
License shall be governed by California law, excluding its 
conflict-of-law provisions. With respect to disputes or any 
litigation relating to this License, the losing party is 
responsible for costs, including without limitation, court costs 
and reasonable attorneys' fees and expenses. The application 
of the United Nations Convention on Contracts for the 
International Sale of Goods is expressly excluded. Any law or 
regulation which provides that the language of a contract shall 
be construed against the drafter shall not apply to this License.

Appendix 

Public Documentation License Notice 

The contents of this Documentation are subject to the Public 
Documentation License Version 1.0 (the "License"); you may 
only use this Documentation if you comply with the terms of 
this License. A copy of the License is available at 
http://www/OpenOffice.org/licenses/PDL.rtf. 

The Original Documentation is _________________. The 
Initial Writer of the Original Documentation is 
______________________ (C) ____. All Rights Reserved. 
(Initial Writer contact(s):_______________[Insert 
hyperlink/alias].)

Contributor(s): 
______________________________________. 

Portions created by ______ are Copyright 
(C)_________[Insert year(s)]. All Rights Reserved.   
(Contributor contact(s):________________[Insert 
hyperlink/alias]).

Note: The text of this Appendix may differ slightly from the 
text of the notices in the files of the Original Documentation. 
You should use the text of this Appendix rather than the text 
found in the Original Documentation for Your Modifications.
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