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Overview

Overview

While the interfaces of OpenOffice.org and Microsoft Office are generally similar, there are
some differences. The purpose of this chapter is to outline those differences and how to work
with them. One of the underlying differences is the degree of integration of the applications.
For instance, it is possible to open a Calc spreadsheet in Calc while working in Writer.

For information on how to customize the interface, see the chapter on Customizing
OpenOffice.org.

Copyright and trademark information
The contents of this Documentation are subject to the Public Documentation License,
Version 1.0 (the "License"); you may only use this Documentation if you comply with the
terms of this License. A copy of the License is available at:
http://www.openoffice.org/licenses/PDL.rtf

The Original Documentation is General Differences in Use between OpenOffice.org and
Microsoft Office. The Initial Writer(s) of the Original Documentation is/are Ian Laurenson ©
2004. All Rights Reserved. (Initial Writer contact(s): hillview@paradise.net.nz. The Initial
Writer contact(s) is to report  errors in the documentation. For questions regarding how to use
the software, subscribe to the Users Mail List and post your question there:
http://support.openoffice.org/index.html.)

All trademarks within this guide belong to legitimate owners.

Feedback
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org.

Acknowledgments
Thanks to the OOoAuthors team for proofreading this work, particularly Danial Carrera and
Jean Hollis Weber.

Modifications and updates

Version Date Description of Change

1.0 5 November 2004 First published version.
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Help

Help

Help in OpenOffice.org is very similar to its equivalent in Microsoft Office.

If you pause the mouse over a button, you will see a tooltip describing the button. (If you
don't see a tooltip, go to the Help menu and select Tips to turn them on.)

Shift + F1 changes the pointer to a question mark. When the question mark pointer is over a
button or control on a dialog, a more detailed description is displayed.

Pressing F1 displays contextual help (based on what is currently selected).

There is an equivalent to the Microsoft Office “Office Assistant”. This is
called the Help Agent. It “lights up,” alerting the user that help is available for
an event that has just happened. Examples are when a user first saves a file, or
when a word gets automatically corrected. The Help Agent can be turned off
and on from the Help menu.

See the Technical Support chapter for more information on getting help.

Zoom – the view percentage

To change the size at which the document is displayed on the monitor, use: View > Zoom or
right-click or double-click the number with a percentage sign next to it on the status bar.

In Writer, the Optimal option zooms the display so that the document is displayed between
left and right margins. The zoom factor is automatically adjusted as the side panels are
displayed.

AutoCorrect / AutoFormat

Writer adds an auto-complete feature to words, so that when a user is typing, Writer tries to
predict what the completion of the word will be. Settings for this feature (including turning it
off) are here:

Tools > Auto Correct/Auto Format... > Word completion.

Menus

One of the differences in menu location is that page layout is considered to be a format, so it
is found under the Format menu (Format > Page...) rather than the File menu.

For customizing menus, see the Customizing OpenOffice.org chapter.
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Personalized menus
There is no personalized menus option. This feature in Microsoft Office reorganizes the
menus so that the most frequently used options are displayed first. However, the degree of
context sensitivity, based on current cursor location, is much greater in OpenOffice.org than
in Microsoft Office. For instance, in Writer, the menu items for working with tables, found in
the Format menu, are only displayed when the cursor is in a table.

In OpenOffice.org there are some menu items that are relevant to the current cursor location,
but which are inactive for some reason. For example the sort option (Tools > Sort) is not
available when nothing is selected. By default these menu items are not displayed. To make
them visible use: Tools > Options > OpenOffice.org > View > Inactive Menu Items.

Toolbars

The top toolbar (default position) is called the Function Bar. The Function Bar is consistent
across the OpenOffice.org applications.

The second toolbar across the top (default location) is the Object Bar. The Object Bar is a
context-sensitive bar which shows the relevant toolbars in response to the cursor's current
position or selection. For example when the cursor is in a table, the object bar provides both a
Table Bar and a Text Bar. To toggle between these bars click the large triangle button at the
right end of the Object Bar.

The toolbar down the left side (default position) is the Main Toolbar. It has the buttons most
relevant to the current application.

Buttons with a small green triangle will display one of the following with a long click,
depending on the button:

• Sub-menus (e.g. the New, Paste, Undo, Redo, AutoText buttons)

• Tear-off toolbars (e.g. Font Color, Highlighting, Insert buttons)

• A quick way of selecting things like number of cells or columns (e.g. Insert table,
Insert Frame, Insert Section)

Moving toolbars
To convert a docked toolbar to a floating toolbar and vice versa: Control + double click a
blank area of the toolbar. To dock a toolbar at a different edge, Control + drag a floating
toolbar to the desired edge.
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Tear-off toolbars
Tear-off toolbars are accessed by giving a long click on a button with a small green triangle.
These toolbars are always floating (they cannot be docked at an edge), but they can float over
the top of other toolbars and docked / floating windows. To move a tear-off toolbar, drag it
by its title bar.

The Draw Functions toolbar
In Microsoft Office the Draw toolbar is, by default, across the bottom of the application
window. 

In Writer and Calc the Draw Functions toolbar is a tear-off toolbar from the Main Toolbar
(down the left by default). To display this toolbar click the Show Draw Functions button
(fourth button down by default).  In Draw and Impress, the tools found on Microsoft Office's
Draw toolbar are found directly on the Main Toolbar.

The Load URL drop-down on the Function bar
The drop-down on the left of the Function Bar is called “Load URL”. It lists up to the last
100 files that have been open in OpenOffice.org. Select a file from the list to open it.

Mouse use

Long click
Some toolbar buttons have a small green triangle in the top right corner of the button. This
green triangle symbolizes that clicking and holding the mouse button down will display a
submenu or tear-off toolbar (see “Tear-off toolbars“ on page 3). When you select a submenu
or button, then the symbol on this button will change to the same symbol. Thus doing a
normal click on these buttons will act in the same way as long clicking and then clicking on
the submenu entry or button on the tear-off toolbar.

Drag and drop
While drag and drop does work, there is less feedback with pointer changing in
OpenOffice.org than in Microsoft Office. For example, when moving the pointer onto a
selected piece of text, the pointer remains the usual I bar rather than changing to an arrow.

Right click
Right clicking in OpenOffice.org does display a context menu but it doesn't select what has
just been right clicked on; the context menu is for what is currently selected.
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Side panes – docked / floating windows

Microsoft Office XP introduced the concept of side panes. These are the closest equivalent to
OpenOffice.org's docked / floating windows. In OpenOffice.org these windows include:

• Navigator to help move around the document (the closest equivalent in Microsoft
Office would be the Outline view in Word)

• Stylist for managing styles

• Gallery (a clip art viewer)

• Function List (available only in Calc)

• Data Source View, sometimes called the beamer (available in Calc and Writer and can
only be docked at the top)

There is no equivalent of the Microsoft Office Clipboard for handling multiple copies.

Docking and undocking
Docking and undocking windows works the same as for the toolbars: Control + Double
click docks / undocks. Control + drag the title bar will shift the edge at which it docks.

It is possible to have two windows in the same area, for example having the Stylist and the
Navigator at the right edge with one above the other rather than side by side. Then the show /
hide and stick / floating buttons work for both docked windows.

Resizing
The docked windows can be resized by moving to the border between its window and the
next window. When the mouse pointer changes to a double-ended arrow, click and drag to
the desired size.

Show / Hide
In addition to hiding/displaying windows, many have their own button that works like a
minimize to the edge button. It is a triangle pointing to the current docked edge to hide it, or
pointing out from the edge to show it.

Stick / Floating pin
With a window floating but docked at an edge, it overlaps the workspace window. Click the
pin to “stick” it so that the workspace window is resized to make the entire width of the
workspace window visible.
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Navigator
The Navigator is activated and deactivated by F5, or the Navigator On/Off button in the
Function Bar or Edit > Navigator. This window shows the different objects in the current
document. For example in Writer it shows the list of headings and has controls similar to
Outline view in Word. The drop-down at the bottom of the Navigator is for selecting which
of the currently open documents has information displayed in the Navigator. (For more
information, see Navigator in each of the applications.)

Stylist
The Stylist can be activated and deactivated by F11, or the Stylist On/Off button in the
Function Bar or Format > Stylist.

To change the type of styles displayed, use the buttons across the top. For example, in Writer
the buttons are Paragraph Styles, Character Styles, Frame Styles, Page Styles and Numbering
Styles. The drop-down at the bottom of the Stylist determines which of these different types
get displayed. For example in Writer, for character styles the options are Hierarchical, All,
Applied and Custom. The style of the current selection is highlighted. See Help > Index >
type “Stylist” > creating new Styles from selections and updating from selections; and
Help > Find > type “Applying Styles” > Applying Styles in Fill Format Mode for how the
other buttons work.

Gallery
The Gallery is activated and deactivated by the Gallery button in the Function Bar or Tools >
Gallery.

Note: There is no default key press.

This is OpenOffice.org's equivalent to Microsoft Office's Media Gallery, except it doesn't
have ties to the Web and there is no search facility. Very little clip-art comes with
OpenOffice.org. To download some public domain clip-art, see http://www.openclipart.org/.

Media in the Gallery is organized by themes. Themes are displayed down the left side of the
Gallery window.

Insert media into Document

To place the media (such as clip art) into the current document:

Drag and drop the media into the document

or

Right click > Insert > Copy
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Add pictures to the Gallery

It is possible to add pictures to existing themes when the icon for the theme is green1.

1) Right click on a theme > Properties... > Files > Find Files...

2) Navigate to (or type in) the top folder. Click Select. OOo will search this folder and all
subfolders for media files.

3) Select the files (by holding down Ctrl for individual files or Shift for blocks of files) that
you wish to be included in the Gallery.

4) Click Add.

Note: It is also possible to drag and drop a picture from the document into the Gallery.

Delete picture from Gallery

To delete a picture from the Gallery:

1) Select the picture.

2) Right Click > Delete.

3) Confirm the deletion.

Note: The link to the picture is removed from the Gallery but the file is not removed from the
disk.

Add a new theme

To add a new theme:

1) Display the Gallery.

2) In the top left of the window is a button New Theme... click it.

3) On the General tab, enter a name for the new theme.

4) On the Files tab, follow the instructions above to add pictures to the gallery.

Data source viewer
The Data source viewer is activated and deactivated by F4 and by the Data sources button in
the Main Toolbar.

The Data source viewer window behaves differently in that it can only be docked at the top.

It is possible to drag and drop fields from data sources to create fields in the current
document.

For working with the Data source viewer, see the chapter on Data Sources.

1 An icon colored something other than green indicates that the folder that stores the theme is read-only for the
current user.
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Page preview

File > Page Preview in OpenOffice.org is the equivalent of Microsoft Office's Print preview.

The Zoom button in OpenOffice.org simply zooms the view; it doesn't provide a pointer with
which the user can select an area to zoom in on.

Keyboard shortcuts

The standard keyboard shortcuts for cut (Control + X), copy (Control+C), paste
(Control+V), undo (Control + Z), redo (Control + Y), save (Control + S), open (Control +
O) and new (Control + N) are the same.

Smart tags

Smart tags are not available in OpenOffice.org. In Microsoft Office XP they are like context
menus for things like pasting text so that the user could alter the way the paste worked.

Special characters / symbols

The equivalent of insert symbols is:

Insert > Special Characters

Note: The dialog displayed doesn't have a second tab for common special characters such as
em-dash. Workarounds are to use AutoFormat/AutoCorrect, AutoText or to record a macro.

File management

Default locations
Use Tools > Options > OpenOffice.org > Paths to set the default locations for file storage.
The two path settings of interest (at this stage) are My Documents and Templates.

My Documents only allows one location. In other words., it is not possible to have a separate
folder for each of the applications. This folder is the default location for File > Save As, and
is the folder that gets displayed when the Default Directory button, , is clicked in the Open
and Save As dialogs.

For templates it is possible to have more than one folder specified. These are the folders that
are shown down the left side of the dialog that gets displayed for File > New > Templates
and Documents (see “Creating new files” on page 8).
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Creating new files
As with Microsoft Office, in OpenOffice.org there are a number of different ways of creating
new files. What is different is that you can initiate the creation of any OpenOffice.org file
type from any application. For instance, it is possible to start creating a spreadsheet while
working in Writer.

Different ways of creating a new document:

• File > New.

• Use the New button on the Function Bar. This button has the long-click feature for
selecting the type of document to be created.

• From a “Quick start” program. For instance, the Microsoft Windows version of
OpenOffice.org has a Quickstart icon in the system tray.

• Control + N.

• Using AutoPilots (OpenOffice.org equivalent to Microsoft Office Wizards):
File > AutoPilot.

Default templates
Each component of OpenOffice.org (Writer, Calc, etc.) has a default template. To change the
default template for a component:

1) Save the template using File > Templates > Save... Category Default. The name of
the template is not important

2) File > Templates > Organize...

3) Double click Default folder.

4) Select the template by clicking on it.

5) Either right click or Commands > Set as Default Template.

Note: The default template in Microsoft Word is always a file called Normal.dot. In
OpenOffice.org there is no special name for the default template files; they can be called
anything. If no template has been specified in OpenOffice.org then the properties for the default
template are those that are directly coded into OpenOffice.org code – an in-built template.

To reset back to the default (in-built) template:

File > Templates > Organize... > Commands > Reset Default Template > 
[xxx Document] where xxx is the type of document to be reset.

Template folder management
To make it easier to manage your templates such as creating and deleting folders (categories),
and importing templates into the folders, use:

File > Templates > Organize... > Double click the desired folder > Commands
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Open and Save As dialogs
Running under Microsoft Windows there is the option of using either the OpenOffice.org
Open and Save As dialogs or the ones provided by Microsoft Windows. To view or change
which type of dialog OpenOffice.org is using:

Tools > Options... > OpenOffice.org > General > Use OpenOffice.org dialogs.

Note: The dialogs provided by Microsoft Windows are not the dialogs used by Microsoft Office!

What follows is for the OpenOffice.org Open and Save As dialogs.

The three buttons in the top right are, from left to right:

• Go up one level in the folder (directory) hierarchy. Note that this is a long-click button
if you want to go up higher than just one level.

• New folder.

• Default Directory (see “Default locations” on page 7).

For OpenOffice.org documents that have been saved with more than one version, use the
version drop-down to select which version you wish to open in read-only mode.

Note: For Microsoft Office documents only the current version can be opened.

The File type field has the same concept in OpenOffice.org as in Microsoft Office – the
ability to specify the type of file to be opened or the format of the file to be saved.

The Read only checkbox opens the file for reading and printing only. Consequently most of
the toolbars disappear and most menu options are disabled. An Edit File button is displayed
on the Function Toolbar to open the file for editing.

It is possible to open files from the web using URLs. In theory it is possible to save files, but
the author hasn't been able to get this to work. Having a local copy and using an FTP program
to copy it to the server feels safer to the author anyway.

File management within an OpenOffice.org Open or Save As dialog

To rename a file:

1) Right click on a file name to display a context menu.

2) Click Rename and the file name will be selected.

3) Typing will replace the selected name or use a left or right arrow key to move the insertion
point to modify the existing name.

To delete a file:

1) Right click on a file name to display a context menu.

2) Click Delete and you will get a confirmation dialog.

Note: Instead of Right click > Delete you can simply press the Del key.

It is not possible to copy and paste files within the dialogs for moving files around.
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Password protection
To protect an entire document from being viewable without a password, there is an option on
the Save As dialog to enter a password. This option is only available for files saved in
OpenOffice.org formats.  OpenOffice.org's password-protection uses strong encryption to
protect your data.

Privacy options
To include or remove personal information (e.g. author’s name) with the document, go to
File > Properties... > General. The Delete button removes information such as editing time.
The Apply User data checkbox includes or removes information such as “Author”.

PDF (Adobe Reader) file creation
All of the applications have the ability to export documents as PDF files. Click on Export
Directly as PDF button on the Main toolbar, or use: File > Export as PDF...  The menu bar
option provides access to choices including the print quality and the range of pages to be
printed to PDF.

Creating web pages (HTML files) overview
This section is based upon an article by Ralph Krause, titled “HowTo: Creating web pages
with OpenOffice.org”. The original document is available at:
http://www.linuxjournal.com/article.php?sid=6289.

All of the OpenOffice.org applications can be used to create web pages. This section
introduces their HTML capabilities.

Writer

Writer's HTML capabilities include saving existing documents in HTML format, creating
new documents as HTML and creating several different types of web pages using a wizard
(or AutoPilot in OpenOffice.org).

The easiest way to create HTML documents is to start with an existing Writer document. You
can view it as it will appear on a web page by using View > Online Layout.

Links can be inserted and modified using the hyperlink dialog. Display the dialog by clicking
the Hyperlink Dialog button on the Function Bar or Insert > Hyperlink. Writing or pasting
a URL will (depending on AutoCorrect/AutoFormat settings) automatically convert to
hyperlinks. 

To edit an existing link, either move the cursor into the link using the keyboard or toggle the
“HYP” to “SEL” in the Status Bar and use the mouse, Edit > Hyperlink. From the
Hyperlink dialog, you can choose the type of link, as well as specify the link's address, text
and how it should be displayed (for example, in a new window). 
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To  turn existing text into a link, simply highlight it before opening the Hyperlink dialog.
You have to click Apply to insert the link into your document before closing the window.

Note: Cross references do not become hyperlinks in an HTML document.

To save in HTML format, select Save As from the File menu and specify HTML document
as the file type.

Note: One thing that Writer doesn't do is replace multiple spaces in the original document with
the HTML code for non-breaking spaces.

Writer can save a large document as a series of HTML files with a table of contents page. To
do this:

1) Decide which headings in the document should be on separate pages and make sure
that they have the same formatting style (for example, Heading 2).

2) File > Send and click on Create HTML Document.

3) In the dialog box that appears, enter the file name to save the pages under. Also
specify which style indicates a new page (as decided on in step 1).

4) Click Save to create the multi-page HTML document. (For those who may be
interested, the resulting HTML files conform to the HTML 3.2 standard.)

OpenOffice.org's wizard, called AutoPilot, allow you to create several types of standard web
pages. To use the AutoPilot:

1) File > AutoPilot > Web Page... .

2) In the dialog, select a template and layout to use. Templates define the structure of the
web page, while layouts determine font styles, colors and page background. Some
templates included with OpenOffice.org are:

• A list with table of contents

• Contact form

• Photo album

• Single column with subheading

• Standard

The standard template provides a document with a page heading in large text, example links,
space for body text and a line indicating when the document was last changed.  Changes in
the template and layout selections are reflected in the document immediately, so that you can
preview them.

To create a template based on your selections, place a check in the Create template box.
This template will be available in the future through File > New > Templates and
Documents.

Click the Create button to close the dialog and edit the document. If you elect to create a
template, the Templates dialog appears, so that the template can be named.
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To edit or view the document's underlying HTML code, View > HTML-Source or click
HTML Source on the Main toolbar.

Calc

Calc can save its files as HTML documents. If the file contains more than one sheet, the
additional sheets will follow one another in the HTML file. Links to each sheet will be placed
at the top of the document. Calc also allows the insertion of links directly into the spreadsheet
by using the Hyperlink dialog.

Draw

It is possible to export drawings as a Macromedia Flash file: File >Export and choose
Macromedia Flash for the file type.

The drawing program allows you to turn your drawings into a series of web pages. These web
pages are created by using:

1) File > Export > select Web Page as the file type, supply a name for the resulting
HTML file, and click Save.

2) In the HTML Export window, select whether to use an existing design for the web
pages or create a new one.

3) Click Next to select the type of web pages to create. The types available are Standard
HTML format, Standard HTML with frames, Automatic and WebCast. There is also
an option for creating a title page for the presentation.

• Standard HTML generates a series of pages, each page containing one slide.
Navigation links are available to move from slide to slide.

• Automatic generates a series of pages, each set with the Refresh meta tag that
causes a browser to automatically cycle through each web page.

• WebCast generates an ASP or Perl application to display the slides.

4) After selecting the type of publication to create, select whether to convert the slides to
GIF or JPG files and what resolution should be used.

5) If Create a title page was chosen in step 3 above, supply the information for it on the
next page. The title contains an author name, e-mail address and home page, along
with any additional information specified

6) In the next page, choose between text or graphics for the links used to navigate
through the slides. For graphical navigation buttons, there are several styles to choose
from.

7) Next select the color scheme to use on the web pages. Available schemes include the
document's existing scheme, one based upon browser colors, and a completely user-
defined scheme.

8) Click the Create button to generate the HTML files.

Note: The HTML and image files are placed in the same directory, so it is advisable to create
unique directories for each drawing.
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Impress

Exporting presentations from OpenOffice.org's Impress application is similar to exporting a
drawing from Draw. Use File > Export and select HTML document as the file type. The only
difference is that there is an option to display each slide's notes along with the slide.

Document properties
Some differences in document properties:

• Summary / Description: OpenOffice.org doesn't include fields for manager or
category.

• Statistics: For Writer this is where you find the word count.

• Custom / User defined: OpenOffice.org provides only four fields. To rename the fields
use Info fields...

• The Internet tab is for dynamic web pages – such as a page saying  “redirecting you
to ...”

Searching for files
There is no Find Files command built-in to OpenOffice.org for finding files that contain
specific text. However for those who are more technically able, a Python script that does this
is available from: http://www.danielnaber.de/loook/.

Working with multiple files
The Window menu displays all of the currently open documents in OpenOffice.org.

Each open document has its own window, so depending on the operating system, use the task
bar or ALT + Tab to switch between the currently open documents. In Microsoft Office it is
possible to use Control + F6 to switch between currently open documents. In OpenOffice.org
F6 is used for accessibility to move to the menu and each of the toolbars. Control +F6 will
make the current document active.

For information on Object Linking and Embedding (OLE), see the chapter on Sharing Files.

In the Windows version of OpenOffice.org, it is possible to copy and paste special cells from
a Calc spreadsheet into a Writer document as a Dynamic Data Exchange (DDE) link. It is
also possible in the Windows version to create a DDE field. Neither of these options is
available in the Linux version, yet opening a file created in the Windows version on a Linux
version works (some modification of the file location may be necessary). If you would like to
know more, see http://www.openoffice.org/issues/show_bug.cgi?id=5317.

In neither version is it possible to have a link to a chart.

For information on what happens with imported files containing DDE links, see the chapter
on Sharing Files.
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Autosaves
To turn on/off autosaving and set the time period:

Tools > Options... > Load/Save > General > AutoSave every

Warning: Autosave will overwrite the current file!

Version control
With version control, you can save more than one version of a file under the one file name. In
Microsoft Office each version contains the changes that have occurred to the document (like
fast saves), in OpenOffice.org each version is complete. To use: File > Versions...

See “Open and Save As dialogs” on page 9 for more information.

Find and Replace

Find and replace are combined in OpenOffice.org.  There isn't a separate menu entry or key
shortcut for replace.

There is no “word forms” search.

Having performed a search and having closed the dialog box, the key shortcut to repeat the
search is: Control + Shift + F.

Searches are paragraph based so there is no way to search for text either side of a paragraph
marker. For example OpenOffice.org cannot search for two blank paragraphs. To get around
this problem and some issues, an alternative macro has been developed. See
IannzFindReplace, available from http://homepages.paradise.net.nz/hillview/OOo/.

Note: Manual page breaks are handled by changing the paragraph format of the first paragraph
on the new page.  When searching for formats this option is grayed out, as there is no way to
search for “manual” page breaks.

Some tips for find and replace
It is common to do several find and replace operations on the same selection.  However
OpenOffice.org doesn't “remember” the original selection. So, before doing the find and
replace, bookmark the selection in Writer or define a range name for the selection in Calc, so
that by using the Navigator, the same range can be quickly reselected.

Doing a “find all” selects all the pieces of text that match the criteria.  It is possible to
perform, on all of these selections, any operation that is possible on a single selection.
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Attributes
The Attributes... button is only available in Writer's Find dialog. This button displays a
dialog with a series of checkboxes to find where a particular attribute has been changed from
the default for the underlying style. for example, the attribute “Font weight” would find
where text had been made bold where the underlying font was not bold (and vice versa).

Note: The attributes settings remain between uses of the Find dialog. This can be frustrating, so
always turn off all of the attribute settings after use.

Formats
This is the same concept as in Microsoft Office. Note that, if formats are used, there is an
option to include searching within styles. For example, searching for bold text would not find
bold text where the style is bold unless this option is checked.

Regular expressions
“Regular expressions” are significantly different in OpenOffice.org from Microsoft Office's
“Use wildcards”. See Help > Index tab > type in “regular expressions”. Some common
examples are in Table 1. To use regular expressions, make sure the Regular expressions
checkbox is checked. On reopening the Find / Replace dialog the Regular Expressions
checkbox is always unchecked.

Note: The asterisk “*” means any number of the preceding character so where in Microsoft
Office you might have just “*” the equivalent in OpenOffice.org is “.*” as “.” stands for any
single character (like Microsoft Office's “?”).

A macro that makes it easier to use regular expressions in Writer, and allows searching for
“page breaks” and for things like multiple blank paragraphs, is available in a document called
IannzFindReplace.sxw available from http://homepages.paradise.net.nz/hillview/OOo/.

Similarity search
The Similarity search option broadens the search so that what is found doesn't have to be
exactly the same as what was specified in the “Search for” field. To specify how different it
can be, click on the ... button next to Similarity search.

Search for styles
Writer and Calc have an option, Search for styles (changes to Within Styles if Format or
Attribute search is used). Check this first if searching for a particular style. The Search for
combo box field changes to listing the used paragraph styles.
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Table 1. Sample regular expressions

Problem Search Replace
Replace multiple tabs with just one tab \t* \t

Replace multiple spaces with just one space. “[:space]” finds both
non-breaking spaces and normal spaces but not tabs (help is
currently incorrect). Type a normal space in the Replace field.

[:space:]*  

Remove leading white space (space or tabs in any combination)
at the start of a paragraph.

^([:space:]|\t)*

Remove trailing white space (space or tabs in any combination at
end of paragraph).

([:space:]|\t)*$

Find paragraphs beginning with the character “a” (the rest of the
paragraph can vary) and replace the whole paragraph with a blank
line

^a.*

Remove a paragraph mark from the end of lines (e.g. when
having pasted text from an e-mail message).

$

Replace paragraph marks with a comma so that there is one long
line rather than many lines.

$ ,

Replace commas with a paragraph mark. , \n

Replace line breaks (Shift+Enter) with paragraph markers. (Note
that \n is used for both the Search and Replace fields. In search it
is interpreted as a newline and in replace as a paragraph mark.
There is not the ability to have a line break in the replace field.)

\n \n

Find the word “the” only (Don't find “then” or “bathe”). \<the\>

Find “ing” at the end of a word, e.g Reading, writing, but not
singer.

ing\>

Find whole word that ends with “ing”. Note there is a space
between the caret and the close square bracket character.

[^ ]*ing\>

Select all numbers at the start of a line where the numbers could
include a period, e.g. 1.1.

^[0-9.]* 

Grammar checking

Currently there is no grammar checking function. To quote the proofreader of this document:
“But this is no great loss. I have reservations about the value of the one available in Microsoft
Word.”
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